如何解决:对应的服务器 tls 为 tls 1.0,小程序要求的TLS版本必须大于等于1.2问题

2019-05-14    次访问   

微信小程序  TLS 版本必须大于等于1.2问题解决

此问题最近在微信小程序开发中,比较常见。

在解决这个问题之前,我们需要了解一下,当前的系统环境是否支持TLS1.2以上,可以参考一下表格:

系统支持

请先确认系统支持TLS1.2以后,进行一下操作:(如不支持请升级系统到支持版本)

windows2008R2在配置SSL做小程序开发时候提示小程序的TLS版本必须大于等于1.2。

解决方法:

请先备份导出HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols的值。如图:

注册表备份

下载

zhixing.zip

下载压缩包,解压后,把里面的txt文件后缀修改成.reg,在服务器上双击执行即可,完成这一步后,重启服务器。




文章均为思乐科技专注网站建设,成都网站建设的成都网站建设公司原创,转载请注明来自https://www.cdsile.com/news/fuwudayi/77786.html
上一篇: gov.cn域名注册流程
下一篇: